KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q321100: COMTI Stops Responding on Second Call with Event 102

Article: Q321100
Product(s): Microsoft SNA Server
Version(s): 4.0
Operating System(s): 
Keyword(s): Kbhostintegserv2000
Last Modified: 09-MAY-2002

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Host Integration Server 2000 
- Microsoft SNA Server, version 4.0 
-------------------------------------------------------------------------------

SYMPTOMS
========

A COM Transaction Integrator (COMTI) method call works one time, and none of the
following calls succeeds until the Component Services application package shuts
down. Each time that a call is unsuccessful, Component Services posts a COMTI
Event 102 in the application event log with the following details:

  Exception description: (1304) COM Transaction Integrator was unable to
  process the method because the Transaction Server is in the process of
  stopping. Retry the operation later.

NOTE: The Component Services application package can shut down in one of the
following ways:

- Automatically: if the "Minutes until idle shutdown" option is set. (The
  default setting is three minutes.)
- Manually: when you open the Component Services manager, right-click the
  Application Package, and then click Shut down.

CAUSE
=====

This problem occurs when you apply COM+ Hotfix Rollup Package 19 or later and if
you use COMTI with SNA Server 4.0 and Host Integration Server 2000.

For additional information, click the article number below to view the article in
the Microsoft Knowledge Base:

  Q318105 INFO: Availability of Windows 2000 Post-Service Pack 2 COM+ Hotfix
  Rollup Package 19

RESOLUTION
==========

Host Integration Server 2000

A supported fix is now available from Microsoft, but it is only intended to
correct the problem described in this article and should be applied only to
systems experiencing this specific problem. This fix may receive additional
testing at a later time, to further ensure product quality. Therefore, if you
are not severely affected by this problem, Microsoft recommends that you wait
for the next Microsoft Host Integration Server 2000 service pack that contains
this fix.

To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information about support costs, please go to the following
address on the World Wide Web:

  http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

NOTE: In special cases, charges that are normally incurred for support calls may
be canceled, if a Microsoft Support Professional determines that a specific
update will resolve your problem. Normal support costs will apply to additional
support questions and issues that do not qualify for the specific update in
question.

The English version of this fix should have the following file attributes or
later:

+---------------------------------+
| File name | Date        | Time  | 
+---------------------------------+
| tagen.dll | 08-Apr-2002 | 09:40 | 
+---------------------------------+

NOTE: Because of file dependencies, the most recent fix that contains the above
files may also contain additional files.



SNA Server 4.0

A supported fix is now available from Microsoft, but it is only intended to
correct the problem described in this article and should be applied only to
systems experiencing this specific problem. This fix may receive additional
testing at a later time, to further ensure product quality. Therefore, if you
are not severely affected by this problem, Microsoft recommends that you wait
for the next Microsoft SNA Server version 4.0 service pack that contains this
fix.

To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information about support costs, please go to the following
address on the World Wide Web:

  http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

NOTE: In special cases, charges that are normally incurred for support calls may
be canceled, if a Microsoft Support Professional determines that a specific
update will resolve your problem. Normal support costs will apply to additional
support questions and issues that do not qualify for the specific update in
question.

The English version of this fix should have the following file attributes or
later:

+---------------------------------+
| File name | Date        | Time  | 
+---------------------------------+
| tagen.dll | 05-Apr-2002 | 15:52 | 
+---------------------------------+

NOTE: Because of file dependencies, the most recent fix that contains the above
files may also contain additional files.



STATUS
======

Microsoft has confirmed this to be a problem in the Microsoft products that are
listed at the beginning of this article.

Additional query words:

======================================================================
Keywords          : Kbhostintegserv2000 
Technology        : kbAudDeveloper kbSNAServSearch kbHostIntegServ2000 kbSNAServ400
Version           : :4.0
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.