Q307991: TCP Session Is Reset After You Apply the Security Rollup Package
Article: Q307991
Product(s): Microsoft Windows NT
Version(s): 4.0 SP6a
Operating System(s):
Keyword(s):
Last Modified: 11-JUN-2002
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The information in this article applies to:
- Microsoft Windows NT Workstation version 4.0 SP6a
- Microsoft Windows NT Server version 4.0 SP6a
- Microsoft Windows NT Server, Enterprise Edition version 4.0 SP6a
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IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
Q256986 Description of the Microsoft Windows Registry
SYMPTOMS
========
After you apply the Windows NT 4.0 Security Rollup Package (SRP), you may not be
able to connect to HTTP or FTP services on that Windows NT 4.0-based server. You
can connect again if you remove the SRP.
CAUSE
=====
If the following registry value is set to 2, clients can establish a TCP session
with the server:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SynAttackProtect
If the client then sends additional requests to the server, the server resets the
TCP session immediately.
RESOLUTION
==========
A supported fix is now available from Microsoft, but it is only intended to
correct the problem described in this article and should be applied only to
systems experiencing this specific problem.
To resolve this problem, contact Microsoft Product Support Services to obtain the
fix. For a complete list of Microsoft Product Support Services phone numbers and
information on support costs, please go to the following address on the World
Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
NOTE: In special cases, charges that are normally incurred for support calls may
be canceled, if a Microsoft Support Professional determines that a specific
update will resolve your problem. Normal support costs will apply to additional
support questions and issues that do not qualify for the specific update in
question.
The English version of this fix should have the following file attributes or
later:
Date Time Version Size File name Platform
---------------------------------------------------------------
15-Nov-2001 21:30 4.0.1381.7109 308,912 Tcpip.sys Alpha
15-Nov-2001 21:34 4.0.1381.7109 174,928 Tcpip.sys x86
NOTE: Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0
Service Pack 6a.
WORKAROUND
==========
WARNING: If you use Registry Editor incorrectly, you may cause serious problems
that may require you to reinstall your operating system. Microsoft cannot
guarantee that you can solve problems that result from using Registry Editor
incorrectly. Use Registry Editor at your own risk.
To work around this problem, change the SynAttackProtect registry value to 0.
NOTE: This setting may expose the Web server to a synchronization attack.
STATUS
======
Microsoft has confirmed this to be a problem in the Microsoft products that are
listed at the beginning of this article.
Additional query words:
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Keywords :
Technology : kbWinNTsearch kbWinNTWsearch kbWinNTW400search kbWinNT400search kbWinNTSsearch kbWinNTSEntSearch kbWinNTS400sp6 kbWinNTS400search kbWinNTSEnt400SP6a kbWinNTW400SP6a
Version : :4.0 SP6a
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbfix
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