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Q306521: SMS: SMS Service Manager May Not Connect

Article: Q306521
Product(s): Microsoft Systems Management Server
Version(s): 2.0 SP3
Operating System(s): 
Keyword(s): kbsms200 kbsms200bug kbsms120 kbsms120bug
Last Modified: 16-JUL-2002

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The information in this article applies to:

- Microsoft Systems Management Server version 2.0 SP3 
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SYMPTOMS
========

You may not be able to connect to a site with Systems Management Server (SMS)
Service Manager unless your user name is added to the SMS security database with
site administer rights, even though the group to which you belong has been
granted the appropriate rights.

This problem can also occur even after you apply the hotfix that is referenced in
the following Microsoft Knowledge Base article:

  Q299435 Cannot Run SMS Service Manager After You Apply a Hotfix

CAUSE
=====

This problem occurs because the group membership is not enumerated properly by
the SMS Component Manager provider.


RESOLUTION
==========

A supported fix is now available from Microsoft, but it is only intended to
correct the problem that is described in this article. Only apply it to systems
that are experiencing this specific problem. This fix may receive additional
testing. Therefore, if you are not severely affected by this problem, Microsoft
recommends that you wait for the next SMS service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information about support costs, visit the following Microsoft
Web site:

  http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

NOTE: In special cases, charges that are ordinarily incurred for support calls
may be canceled if a Microsoft Support Professional determines that a specific
update will resolve your problem. The usual support costs will apply to
additional support questions and issues that do not qualify for the specific
update in question.

The English-language version of this fix should have the following file
attributes or later:

  Date      Time   Version        Size     File name    Platform
  --------------------------------------------------------------
  03/01/01  14:30  2.0.1493.3182  171,792  Compmgr.exe  Alpha 
  03/01/01  14:30  2.0.1493.3182  121,440  Compmgr.exe  Intel

NOTE: Due to file dependencies, the most recent hotfix or feature that contains
the above files may also contain additional files.



WORKAROUND
==========

To work around this problem, add rights for the user to the SMS Security Rights
node of the SMS Administrator console. For example, if the user's logon name is
"Bob", and Bob is logged on to the Corporate domain, add a security right for
the Site class or for the instance that you want that allows Administer rights
for the user Corporate\Bob. Repeat this step for each user who needs to use SMS
Service Manager.

STATUS
======

Microsoft has confirmed that this is a problem in the Microsoft products that
are listed at the beginning of this article. This problem was first corrected in
the Systems Management Server 2.0 Service Pack 4 Hotfix Rollup Package (HRP).

For additional information about the SMS 2.0 SP4 HRP, click the article number
below to view the article in the Microsoft Knowledge Base:

  Q323206 SMS: List of Bugs Fixed in the Systems Management Server 2.0 SP4 HRP

MORE INFORMATION
================

How to Install the Hotfix
-------------------------

This hotfix updates SMS Service Manager. This hotfix should be applied to any
system on which the SMS Administrator console has been installed, including each
primary site server.

How to Use the Hotfix Installer:

NOTE: The following method works only on the Intel-based platform.

To use the hotfix installer:

1. Copy the hotfix folder structure to a share on your network. The Q306521.exe
  file is a Microsoft Windows Installer file that updates the specific files on
  your site server.

2. Log on to your site server by using an account with administrative
  privileges.

3. On the site server, quit the SMS Administrator console.

4. Run Q306521.exe, and then follow the directions in the wizard. You can run
  the program in Quiet mode by using the /s switch.

How to Manually Install the Hotfix:

To manually install the hotfix:

1. On the computer that you want to update, verify that the SMS Administrator
  console and the SMS Service Manager programs are not running.

2. Replace the Compmgr.exe file in the SMS_root\Bin\Platform folder with the
  version of the Compmgr.exe file that you obtained from the hotfix.

NOTE: For this hotfix to be effective, Windows Management Instrumentation (WMI)
on the affected computers must be version 1.5 (1085) or later. You must upgrade
affected computers that are running WMI 1.1 (698) must to version 1.5. Microsoft
Windows 2000-based computers include WMI 1.5, by default. Microsoft Windows NT
4.0-based computers that have had only the SMS Administrator console or the SMS
client installed have WMI 1.1 installed unless you upgraded it separately.

You can download the upgrade from the following Microsoft Web site:

  http://www.microsoft.com/downloads/release.asp?ReleaseID=18490


Additional query words: prodsms

======================================================================
Keywords          : kbsms200 kbsms200bug kbsms120 kbsms120bug 
Technology        : kbSMSSearch kbSMS200SP3
Version           : :2.0 SP3
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

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