Q275602: XADM: Microsoft Exchange Server Information Store May Stop After
Article: Q275602
Product(s): Microsoft Exchange
Version(s): 5.5
Operating System(s):
Keyword(s): exc55
Last Modified: 02-NOV-2000
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The information in this article applies to:
- Microsoft Exchange Server, version 5.5
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SYMPTOMS
========
The Exchange Server information store may stop, and the following error messages
may be logged in the application event log:
- Event ID: 125
Source: ese97
Type: Error
Date: 13.8.00
Time: 6:30:12 Am
Description:
MSExchangeIS (521) Unable to create the log. The drive may be read-only, out
of disk space, misconfigured, or corrupted. Error -1811.
- Event ID: 1111
Source: MsexchangeIS
Type: Error
Date: 13.8.00
Time: 6:30:18 Am
An error occurred while writing to the database log file. Attempting to stop
the Microsoft Exchange Information Store.
- Event ID: 193
Source: ese97
Type: Error
Date: 13.8.00
Time: 6:30:38 Am
Description:
MSExchangeIS (521) The database engine failed with error -510 while trying to
log the commit of a transaction. To ensure database consistency, the process
was terminated. Simply restart the process to force database recovery and
return the database to a consistent state.
- Event ID: 1005
Source: MSExchangeSA
Description: Unexpected error 0xc0040000 network problems are preventing
connection to the MS Exchange server computer. MSExchange server Information
Store id # 80040115-0514-000006bf occurred.
- Event ID: 7
Source: MSExchangeES
Description: An unexpected error occurred 0x80040115 occurred in maintenance
thread.
- Event ID: 1005 Source: MSExchangeSA
Description: Unexpected error 0xc0040000 The Microsoft Exchange server
computer is not available. Either there are network problems or the MS
computer is down for maintenance. MSExIS id 804011d-0526-000000 occurred.
If you restart the Information Store service, the restart does not work and the
following informational and error messages are logged in the application event
log:
- Event ID: 100
Source: ESE97
Type: Information
Category: General
Description:
MSExchangeIS -Process ID- The database engine-version- started.
- Event ID: 108
Source: ESE97
Type: Information
Category: Logging/Recovery
Description: MSExchangeIS -Process ID- The database engine is initiating
recovery steps.
- Event ID: 109
Source: ESE97
Type: Information
Category: Logging/Recovery
Description:
MSExchangeIS -Process ID- The database engine is replaying log file
exchsrvr\MDBDATA\edbxxxxx.log.
- Event ID 0
Source ESE97
MSExchangeIS (466) -515
- Event ID: 1120
Source: MSExchangeIS
Description: Error 0xfffffdfd initializing the Microsoft Exchange Server
Information Store database
- Event ID 5000
Source MSExchangeIS
Description: Unable to initialize the Microsoft Exchange Server Information
Store service. Error 0xfffffdfd
CAUSE
=====
This issue can occur because when you restore an earlier online backup to an
empty Mdbdata folder (or restore an earlier online backup with the "erase all
existing data" option) and start the Information Store service, a new Edb.log
file is created with the current log generation. After you copy the saved
transaction logs back to the Mdbdata folder, the transaction logs seem to be in
the correct sequence; however, the copied transaction logs' generation number is
equal to or greater than the Edb.log file number.
One of the transaction logs has the same log generation as the Edb.log file.
Because of the already existing corresponding log, the Edb.log file cannot be
renamed into the next number after the Edb.log file reaches 5 megabytes (MB).
This causes the information store to stop and leaves the databases in an
inconsistent state.
RESOLUTION
==========
To resolve this issue, you can use one of the two following methods. You lose
data with both methods. The amount of data that you lose depends on the
situation, and cannot be foreseen.
Method 1
--------
This is the fastest method, but this method is likely to involve more data loss.
1. Run the eseutil /ml command on the Edb.log file to find out the log
generation number of the Edb.log file.
2. Delete all transaction logs that are equal to or greater than the Edb.log
file number. Start the information store again.
Method 2
--------
This method is more time consuming, but in most cases involves less data loss.
1. Restore the information store databases from an online backup again (either
restore the databases to an empty Mdbdata folder or click "erase existing
data").
2. Copy the transaction logs that were saved before in the first online backup
to the Mdbdata folder.
3. Make sure that the log files are concurrent in number, and then start the
information store again.
NOTE: Transaction logs can only be replayed into the database during a
restoration operation before you start the service.
Additional query words:
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Keywords : exc55
Technology : kbExchangeSearch kbExchange550 kbZNotKeyword2
Version : :5.5
Issue type : kbprb
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