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Q271711: XADM: Autoforward Rules May Be Disabled When Using Antivirus API

Article: Q271711
Product(s): Microsoft Exchange
Version(s): 5.5 SP3
Operating System(s): 
Keyword(s): exc55sp3 kbExchange550preSP4fix kbExchange550sp4Fix kbgraphxlinkcritical
Last Modified: 18-JUN-2002

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The information in this article applies to:

- Microsoft Exchange Server, version 5.5 SP3 
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SYMPTOMS
========

When a mailbox that contains an autoforward rule attempts to process the rule,
if a message contains an attachment and the server uses a program that is based
on the antivirus application programming interface (API), the information store
may disable the autoforward rule.

The client receives a "Rule In Error" error message that lists the name of the
rule with the reason "Unknown Error."

CAUSE
=====

This issue can occur because the antivirus API scans any attachments.

If the information store does not detect this condition when the attachment is
being scanned, the information store disables the rule.

RESOLUTION
==========

To resolve this problem, obtain the latest service pack for Exchange Server 5.5.
For additional information, please see the following article in the Microsoft
Knowledge Base:

  Q191914 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack


NOTE: When you start this version of the information store, the information store
databases are automatically upgraded to a new format. After the databases have
been upgraded, you can restore an earlier version of the Store.exe file on the
server, but only if it is version 5.5.2652.68 or later. If you restore a
Store.exe file earlier than version 5.5.2652.68 after the database has been
upgraded, you are no longer able to start the information store. For additional
information, click the article number below to view the article in the Microsoft
Knowledge Base:

  Q244976 XADM: Event ID 1197 and 1005 When Starting the Information Store

The following files are available for download from the Microsoft Download
Center:

  x86: DownloadDownload Q248838engi.exe now
  (http://www.microsoft.com/downloads/release.asp?ReleaseID=25443)
  Alpha: DownloadDownload Q248838enga.exe now
  (http://www.microsoft.com/downloads/release.asp?ReleaseID=25444)

For additional information about how to download Microsoft Support files, click
the following article number to view the article in the Microsoft Knowledge
Base:

  Q119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current
virus-detection software that was available on the date that the file was
posted. The file is stored on secure servers that prevent any unauthorized
changes to the file.


STATUS
======

Microsoft has confirmed that this is a problem in Microsoft Exchange Server
version 5.5 Service Pack 3. This problem was first corrected in Exchange Server
5.5 Service Pack 4.

MORE INFORMATION
================

After this fix is applied, the information store properly detects this condition
and waits the amount of time that is specified in the OpenRetryDelay registry
key.


Additional query words: avapi rules auto forward disable mapi vapi

======================================================================
Keywords          : exc55sp3 kbExchange550preSP4fix kbExchange550sp4Fix kbgraphxlinkcritical 
Technology        : kbExchangeSearch kbZNotKeyword2 kbExchange550SP3
Version           : :5.5 SP3
Issue type        : kbbug
Solution Type     : kbfix

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