KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q270874: ELL Err Msg: Encarta <Language> Cannot Find the Software…

Article: Q270874
Product(s): Microsoft Home Multimedia Titles
Version(s): 
Operating System(s): 
Keyword(s): kb3rdparty kbenv kberrmsg kbimu kbFAQ
Last Modified: 06-AUG-2002

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Encarta Language Learning French 
- Microsoft Encarta Language Learning French Deluxe 
- Microsoft Encarta Language Learning Spanish 
- Microsoft Encarta Language Learning Spanish Deluxe 
-------------------------------------------------------------------------------

SYMPTOMS
========

When you install one of the Encarta Language Learning programs listed at the
beginning of this article, you may receive any of the following error messages:

   - Setup failed to install the L&H PCMM ASR1600 for Windows V3.

   - Setup initialization error 105.

   - Tosexe has caused an invalid page fault in module unknown.

   - Unable to locate one of the components needed to run.

In addition, if you attempt to start one of the Encarta Language Learning
programs listed at the beginning of this article, you may receive one of the
following error messages:

   - Encarta Spanish cannot find the software components it needs to run Speech
  Recognition. To correct this problem, remove and then reinstall Encarta
  Spanish.

   - Encarta French cannot find the software components it needs to run Speech
  Recognition. To correct this problem, remove and then reinstall Encarta
  French.

   - Tosexe has caused an invalid page fault in module unknown.

CAUSE
=====

This behavior can occur if either of the following conditions is true:

- The Encarta Language Learning speech recognition component is not installed
  correctly.

  -or-

- iRiS or McAfee Antivirus program is running.

RESOLUTION
==========

To resolve this issue, quit the antivirus program if running (remove iRiS),
uninstall the Encarta Language Learning program and all the Encarta Language
Learning speech recognition components, and then reinstall them. To do this, use
the following methods in the order in which they are presented.

Quit iRiS Antivirus
-------------------

For information about how to do this, consult your program documentation or visit
the Computer Associates Web site for support options:

  http://www.antivirus.cai.com

Quit McAfee Antivirus
---------------------

For information about how to do this, consult your program documentation or visit
the McAfee Web site for support options:

  http://www.mcafee.com

Uninstall the Encarta Language Learning Program
-----------------------------------------------

NOTE: If you uninstall the Encarta Language Learning program, you delete all of
the saved student information.

For additional information about how to back up student data, click the article
number below to view the article in the Microsoft Knowledge Base:

  Q270744 Uninstalling Software Removes User Information

To Uninstall the Encarta Language Learning program and all of the speech
recognition components:

1. Quit all of the programs that are running on your computer.

2. Click Start, point to Settings, and then click Control Panel.

3. Double-click Add/Remove Programs.

4. On the Install/Uninstall tab, double-click one of the following programs that
  you want to uninstall:

  Encarta Language Learning French
  Encarta Language Learning French Deluxe
  Encarta Language Learning Spanish
  Encarta Language Learning Spanish Deluxe

5. Follow the instructions on the screen to uninstall the program, and then
  click OK.

  NOTE: If you are prompted to select an uninstall method for the program, click
  Automatic.

6. On the Install/Uninstall tab, double-click the appropriate speech recognition
  component for the version of Encarta Language Learning that you uninstalled.

   - Encarta Language Learning French or Encarta Language Learning French
     Deluxe:

  L&H PC/MM ASR1600 for Windows V3 French

   - Encarta Language Learning Spanish or Encarta Language Learning Spanish
     Deluxe:

  L&H PCMM ASR1600 for Windows V3 Mexican Spanish

7. Follow the instructions on the screen to uninstall the component, and then
  click OK.

8. On the Install/Uninstall tab, double-click the following component:

  L&H PCMM ASR1600 for Windows V3 Engine

9. Follow the instructions on the screen to uninstall the component, and then
  click OK.

10. On the Install/Uninstall tab, double-click the following component:

  L&H PCMM ASR1600 for Windows V3 Basic

11. Follow the instructions on the screen to uninstall the component, and then
  click OK.

12. Close Control Panel.

13. Delete the following folders:

  C:\Asr3232
  c:\windows\lhsp

14. Delete the following file:

  C:\Windows\ASR3232.DLL

15. Restart the computer.

How to Edit the Registry
------------------------

IMPORTANT: This section contains information about editing the registry. Before
you edit the registry, you should first make a backup copy of the registry files
(System.dat and User.dat).

For information about how to edit the registry, view the "Changing Keys And
Values" online Help topic in Registry Editor (Regedit.exe). Note that you should
make a backup copy of the registry files (System.dat and User.dat) before you
edit the registry.

WARNING: Using Registry Editor incorrectly can cause serious problems that may
require you to reinstall Windows. Microsoft cannot guarantee that problems
resulting from the incorrect use of Registry Editor can be solved. Use Registry
Editor at your own risk.

1. Click on Start, Run, and type "Regedit" (without the quotation marks).

2. Click on Registry and choose the "Export Registry File" option.

3. Save it on the Desktop and give it a title such as "Regbackup".

4. Expand the following folders by clicking the plus sign (+) in front of them:

  HKEY_Current_User
  Software

5. Right click on the folder "L&H" and click Delete.

6. Click Yes to confirm the deletion of the registry keys.

7. Expand the following folders by clicking the plus sign (+) in front of them:

  HKEY_Local_Machine
  Software

8. Right click on the folder "L&H" and click Delete.

9. Click Yes to confirm the deletion of the registry keys.

10. Close the Registry Editor.

Clean Boot Your Computer
------------------------

To clean boot your computer, use the appropriate method for your version of
Microsoft Windows.

Microsoft Windows Millennium Edition (Me):

For additional information about how to perform a clean boot, click the article
number below to view the article in the Microsoft Knowledge Base:

  Q267288 How to Perform a Clean Boot in Windows Millennium Edition

Microsoft Windows 98:

Run the System Configuration Utility (Msconfig.exe) to perform a clean boot. To
do this, follow these steps:

1. Click Start, and then click Run.

2. In the Open box, type "msconfig" (without the quotation marks), and then
  click OK.

3. Click the General tab. Click Selective Startup, and then click to clear the
  following check boxes:

  
   - Process Config.sys File
   - Process Autoexec.bat File
   - Process Winstart.bat File (if available)
   - Process Win.ini File
   - Load Startup Group Items

4. Click OK. When you are prompted to restart the computer, do so.

For additional information about how to clean boot Windows 98, click the article
number below to view the article in the Microsoft Knowledge Base:

  Q192926 How to Perform Clean-Boot Troubleshooting for Windows 98


NOTE: To restore your original startup configuration, rerun the System
Configuration Utility (Msconfig.exe), click the General tab, and then click
Normal Startup.

Microsoft Windows 95:

1. Restart the computer. When you see the "Starting Windows 95" message, press
  the F8 key, and then select Command Prompt Only from the Startup menu.

2. At the command prompt, type "win" (without the quotation marks), and then
  press ENTER. Press and hold down the SHIFT key until the Windows startup
  sequence is completed.

3. Turn off any antivirus or disk tool programs that are installed on the
  computer.

  For information about how to disable these programs, see the printed or online
  documentation for the program.

4. Quit all running programs except Explorer and Systray. To do this, press
  CTRL+ALT+DELETE, click the program that you want to quit, and then click End
  Task.

  If you receive a message stating that the program is busy or not responding,
  click End Task again.

5. Repeat step 4 to quit all programs except Explorer and Systray.

For additional information about how to clean boot Windows 95, click the article
number below to view the article in the Microsoft Knowledge Base:

  Q177604 Multimedia: Troubleshooting Using Clean Boot of Windows 95

NOTE: To restore your original Startup options, restart the computer as usual,
and then turn on any antivirus or disk tool programs installed on the computer.
For information about how to turn on these programs, see the printed or online
documentation for the program.

Install the Speech Recognition Component
----------------------------------------

To install the Speech Recognition components that are included with the Encarta
Language Learning program:

1. Insert the "Encarta Language Learning Disk 1: Installation and Resources"
  CD-ROM into the CD-ROM drive. Press and hold down the SHIFT key while you
  insert the CD-ROM to prevent Setup from starting automatically.

2. Click Start, click Run, type the following line in the Open box, and then
  click OK.

  <cdrom>:\aamsstp\speech\asr1600\basic\setup_b.exe

  where <cdrom> is the drive letter of the CD-ROM drive.

3. Follow the instructions on the screen to install the Basic Package.

4. Click Start, click Run, type the following line in the Open box, and then
  click OK

  <cdrom>:\aamsstp\speech\asr1600\engn44\setup_b.exe

5. Follow the instructions on the screen to install the Engine Package.

6. Click Start, click Run, type the appropriate line for your version of the
  Encarta Language Learning program in the Open box, and then click OK.

   - For Encarta Language Learning French and Encarta Language Learning French
     Deluxe:

  <cdrom>:\aamsstp\speech\asr1600\frf_44v1.01\setup_b.exe

   - For Encarta Language Learning Spanish and Encarta Language Learning
     Spanish Deluxe:

  <cdrom>:\aamsstp\speech\asr1600\spm_44v1.01\setup_b.exe

7. Follow the instructions on the screen to install the Language Package.

Make sure a previous setup is not already running in the background. To do this,
use the following steps:

1. Press CTRL+ALT+DEL.

2. In Close Program, click Runsetup.exe, and then click End Task.

NOTE: Repeat the above steps for each speech component installation.

Reinstall the Encarta Language Learning Program
-----------------------------------------------

To reinstall the Encarta Language Learning program:

1. Quit all of the programs that are running on your computer.

2. Insert the "Language Learning Disk 1: Installation and Resources" CD-ROM into
  the CD-ROM drive.

  If the Encarta Language Learning Setup program does not automatically start,
  click Start, click Run, type the following line in the Open box, and then
  click OK

  <cdrom>:\setup

3. Follow the instructions on the screen to install the Encarta Language
  Learning program.

Additional query words: multi multi-media media mm ellf ells remove unable

======================================================================
Keywords          : kb3rdparty kbenv kberrmsg kbimu kbFAQ 
Technology        : kbHomeProdSearch kbHomeMMsearch kbEncartaSearch kbHLangSpanish kbHLangFrench
Version           : :
Issue type        : kbprb

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.