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Q265270: SMS: Assigned Programs Are Not Started After SMS Installation

Article: Q265270
Product(s): Microsoft Systems Management Server
Version(s): 2.0 SP2
Operating System(s): 
Keyword(s): kbsms200 kbsms200bug kbsms120 kbsms120bug
Last Modified: 06-AUG-2002

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Systems Management Server version 2.0 SP2 
-------------------------------------------------------------------------------

SYMPTOMS
========

After you initial System Management Server (SMS), installation pending
advertisements are not run until one of the following events occurs:

- If the user logs off and then logs back on.

  -or-

- If the user opens the Advertised Programs tool in Control Panel.

  -or-

- If the user manually starts Launch32.exe

This problem occurs only if the user has low permission levels on a computer that
is running Windows 2000.

CAUSE
=====

This problem can occur because the SMS client depends on the presence of
Launch32.exe to determine if a user is logged on.

When a user with low permission levels installs the SMS client software, the
installation does not work before Launch32.exe is run. The installation is later
completed remotely by the site server; however, because Launch32.exe is not
running, the user who is logged on is not detected and software distribution
that depends on this state does not occur.

RESOLUTION
==========

A supported fix is now available from Microsoft, but it is only intended to
correct the problem that is described in this article. Only apply it to systems
that are experiencing this specific problem. This fix may receive additional
testing. Therefore, if you are not severely affected by this problem, Microsoft
recommends that you wait for the next SMS service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information about support costs, visit the following Microsoft
Web site:

  http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

NOTE: In special cases, charges that are ordinarily incurred for support calls
may be canceled if a Microsoft Support Professional determines that a specific
update will resolve your problem. The usual support costs will apply to
additional support questions and issues that do not qualify for the specific
update in question.

The English-language version of this fix should have the following file
attributes or later:

 Date        Time    Size       File name        Platform  Version
 -----------------------------------------------------------------------
 06/10/2000  08:50a    233,312  Abnwcli.dll      Intel     2.0.1493.2147
 06/10/2000  08:50a    259,936  Bindclin.dll     Intel     2.0.1493.2147
 06/10/2000  09:05a    369,920  Boot32nd.exe     Intel     2.0.1493.2150
 06/10/2000  09:05a    369,920  Boot32nw.exe     Intel     2.0.1493.2150
 06/10/2000  09:05a    369,920  Boot32wn.exe     Intel     2.0.1493.2150
 06/10/2000  10:10a  1,323,921  Ccmcore.exe      Intel     2.0.92.1
 06/10/2000  10:10a  3,377,845  Clicore.exe      Intel     2.0.1493.2163
 06/10/2000  09:05a    128,864  Cliex32.dll      Intel     2.0.1493.2150
 06/10/2000  09:20a     87,920  Clisvcl.exe      Intel     2.0.1493.2153
 06/10/2000  10:10a      8,512  Cliver.exe       Intel     2.0.1493.2163
 06/10/2000  10:10a         67  Compverbase.ini  Intel                   
 06/10/2000  08:50a    157,536  Falclin.dll      Intel     2.0.1493.2147
 06/10/2000  08:50a    338,272  Mslmclin.dll     Intel     2.0.1493.2147
 06/10/2000  08:50a    269,664  Ndsclin.dll      Intel     2.0.1493.2147
 11/09/1999  07:53p    762,688  Preinst.exe      Intel     2.0.1250.7
 06/10/2000  09:05a    541,920  Smsman.exe       Intel     2.0.1493.2150
 06/10/2000  08:50a    411,920  Abnwcli.dll      Alpha     2.0.1493.2147
 06/10/2000  09:05a    580,368  Boot32nd.exe     Alpha     2.0.1493.2150
 06/10/2000  09:05a    580,368  Boot32nw.exe     Alpha     2.0.1493.2150
 06/10/2000  09:05a    580,368  Boot32wn.exe     Alpha     2.0.1493.2150
 06/10/2000  10:10a  1,925,707  Ccmcore.exe      Alpha     2.0.92.1
 06/10/2000  10:10a  4,423,071  Clicore.exe      Alpha     2.0.1493.2163
 06/10/2000  09:05a    203,536  Cliex32.dll      Alpha     2.0.1493.2150
 06/10/2000  09:20a    124,688  Clisvcl.exe      Alpha     2.0.1493.2153
 06/10/2000  10:10a     13,584  Cliver.exe       Alpha     2.0.1493.2163
 06/10/2000  10:10a         67  Compverbase.ini  Alpha                  
 06/10/2000  08:50a    286,480  Falclin.dll      Alpha     2.0.1493.2147
 06/10/2000  08:50a    578,832  Mslmclin.dll     Alpha     2.0.1493.2147
 06/10/2000  09:05a    838,928  Smsman.exe       Alpha     2.0.1493.2150

NOTE: Due to file dependencies, the most recent hotfix or feature that contains
these files may also contain additional files.



How to Use the Hotfix Installer:

NOTE: You can use this method only on Intel-based computers.

1. Copy the hotfix folder structure to a local folder on your site server or to
  a share on your network. It is important to keep the folder structure intact
  because the Q265270.exe update is dependant on the folder structure. The
  Q265270.exe file is a Microsoft Windows Installer file that updates specific
  files on your site server.

2. Log on to your site server by using an account with administrative
  privileges.

3. On the site server, close the Systems Management Server Administrator
  console.

4. Run the Q265270.exe file and follow the directions in the wizard.

How to Manually Install the Hotfix:

NOTE: You can use this method for both Intel-based and Alpha-based primary site
servers.

1. Copy the hotfix folder structure to a local folder on your site server or to
  a share on your network.

2. Close the Systems Management Server Administrator console.

3. Stop all SMS services.

4. Copy the following files from the appropriate hotfix folder to the specified
  path, where <Platform> is either I386 or Alpha. A site server that is
  running on an Intel-based platform needs only the hotfix files from the I386
  hotfix folder. A site server that is running on an Alpha-based platform needs
  only the hotfix files from the Alpha hotfix folder.

  SMS\Bin\<Platform> folder:

  Abnwcli.dll
  Abnwsvr.dll
  Baseobj.dll
  Bindclin.dll
  Boot32nd.exe
  Boot32nw.exe
  Boot32wn.exe

  SMS\Bin\<Platform>\00000409 folder:

  Smsman.exe

  SMS\Bin\<Platform>\System32 folder:

  Mfc42.dll
  Mfc42u.dll
  Msvcirt.dll
  Msvcrt40.dll

  Inboxes\Clicomp.src\Licmtr\<Platform> folder:

  Msvcrt.dll

  SMS\Licmtr\Odbc\<Platform> folder:

  Msvcrt40.dll (in the SMS\Bin\<Platform>\System32 folder)

  SMS\Inboxes\Clicomp.src\Base\<Platform> folder:

  Ccmcore.exe
  Clicore.exe

  SMS\Inboxes\Clicomp.src\Base folder:

  Comp1130.ini

  SMS\Inboxes\Clicomp.src\Smsapm32\<Platform> folder:

  Apasetup.exe

  SMS\Inboxes\Clicomp.src\Smsapm32 folder:

  Comp1103.ini

  SMS\Inboxes\Clicomp.src\Swdist folder:

  Comp1103.ini

  SMS\Inboxes\Clicomp.src\Swdist\<Platform> folder:

  Swdist.exe

5. Restart the SMS_SITE_COMPONENT_MANAGER service.

STATUS
======

Microsoft has confirmed that this is a problem in the Microsoft products that
are listed at the beginning of this article.

Additional query words: prodsms

======================================================================
Keywords          : kbsms200 kbsms200bug kbsms120 kbsms120bug 
Technology        : kbSMSSearch kbSMS200SP2
Version           : :2.0 SP2
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

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