KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q259219: XADM: Incorrect Year 2000 Date In the Sent and Received Logs

Article: Q259219
Product(s): Microsoft Exchange
Version(s): winnt:4.0 SP5
Operating System(s): 
Keyword(s): exc4sp1
Last Modified: 08-MAY-2002

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Exchange Server, version 4.0 SP5 
-------------------------------------------------------------------------------


SYMPTOMS
========

If you send messages by using the Microsoft Mail (PC) message transfer agent
(PCMTA) from the Microsoft Mail Connector between Exchange Server and a
Microsoft Mail (MS Mail) postoffice, the Sent.log and Recv.log files contain an
incorrect date for the year 2000. The date format that is displayed for the year
2000 in the Sent.log and Recv.log is the following:

  24/02/10 18:01 11689 KEAAU1/KEASYD/$SYSTEM

CAUSE
=====

This problem can occur if the Microsoft Mail Connector does not correctly
convert the date for the year 2000 to a two-digit format, which is required for
the Sent.log and Recv.log files.

RESOLUTION
==========

A supported fix is now available from Microsoft, but it is only intended to
correct the problem that is described in this article. Apply it only to
computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the
fix. For a complete list of Microsoft Product Support Services phone numbers and
information about support costs, visit the following Microsoft Web site:

  http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

NOTE: In special cases, charges that are ordinarily incurred for support calls
may be canceled if a Microsoft Support Professional determines that a specific
update will resolve your problem. The usual support costs will apply to
additional support questions and issues that do not qualify for the specific
update in question.

The English version of this fix should have the following file attributes or
later:

Component: Microsoft Mail Connector

+----------------------+
| File name  | Version | 
+----------------------+
| Async.exe  | N/A     | 
+----------------------+
| Xtnmsg.dll | N/A     | 
+----------------------+



STATUS
======

Microsoft has confirmed that this is a problem in Microsoft Exchange Server
version 4.0 Service Pack 5.

Additional query words: y2k

======================================================================
Keywords          : exc4sp1 
Technology        : kbExchangeSearch kbZNotKeyword2 kbExchange400SP5
Version           : winnt:4.0 SP5
Hardware          : ALPHA x86
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.