KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q258319: XADM: Uuencode Long DBCS Filename Attachment Causes Disk Full

Article: Q258319
Product(s): Microsoft Exchange
Version(s): winnt:5.5 SP2,5.5 SP3
Operating System(s): 
Keyword(s): exc55sp2 exc55sp3 kbExchange550preSP4fix kbExchange550sp4Fix kbgraphxlinkcritical
Last Modified: 01-JUN-2001

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Exchange Server, versions 5.5 SP2, 5.5 SP3 
-------------------------------------------------------------------------------


SYMPTOMS
========

When you send a uuencoded e-mail message that has attachment files with certain
conditions, a temporary file may grow until it consumes all of the disk space or
the information store service is shut down. This issue may also occur when you
download such an e-mail message from the server by using a Post Office Protocol
version 3 (POP3) or Internet Message Access Protocol Version 4rev1 (IMAP4)
client.

An attachment file with the following conditions can cause this issue:

- The file includes double-byte character set (DBCS) characters in the file
  name.

- The length of the file name exceeds 246 bytes after the file name is
  converted from the SJIS character set to the JIS character set.

- The file is encoded by using uuencode.

- The codepage of the message is the JIS character set.

The temporary file is created in one of the following folders (when Exchange
Server is installed in drive C by default):

- If you send the attachment file, the temporary file is created in the
  C:\Exchsrvr\Imcdata\Out folder.

- If you download the attachment file, the temporary file (the *.stf file) is
  created in the C:\Exchsrvr\Mdbdata folder.

CAUSE
=====

This issue can be caused by the information store service, if a file name that
includes DBCS characters exceeds 246 bytes after the file name is converted from
SJIS to JIS. If this file was attached to an e-mail message, the length of file
name exceeds the size of destination buffer and causes an error. The conversion
is retried, which results in an endless loop that emits the same file name over
and over while the temporary file grows in size.

RESOLUTION
==========

To resolve this problem, obtain the latest service pack for Exchange Server 5.5.
For additional information, click the following article number to view the
article in the Microsoft Knowledge Base:

  Q191914 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack


The following files are available for download from the Microsoft Download
Center:

  x86: DownloadDownload Q248838engi.exe now
  (http://www.microsoft.com/downloads/release.asp?ReleaseID=25443)
  Alpha: DownloadDownload Q248838enga.exe now
  (http://www.microsoft.com/downloads/release.asp?ReleaseID=25444)

For additional information about how to download Microsoft Support files, click
the following article number to view the article in the Microsoft Knowledge
Base:

  Q119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current
virus-detection software that was available on the date that the file was
posted. The file is stored on secure servers that prevent any unauthorized
changes to the file.


STATUS
======

Microsoft has confirmed that this is a problem in Microsoft Exchange Server
version 5.5 Service Pack 2 and Service Pack 3. This problem was first corrected
in Exchange Server 5.5 Service Pack 4.

Additional query words:

======================================================================
Keywords          : exc55sp2 exc55sp3 kbExchange550preSP4fix kbExchange550sp4Fix kbgraphxlinkcritical 
Technology        : kbExchangeSearch kbZNotKeyword2 kbExchange550SP2 kbExchange550SP3
Version           : winnt:5.5 SP2,5.5 SP3
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.