Q255284: SMS: PCM Incorrectly Runs Newly Available Expired Jobs
Article: Q255284
Product(s): Microsoft Systems Management Server
Version(s): winnt:1.2 SP4
Operating System(s):
Keyword(s): kbsms120 kbsms120bug
Last Modified: 06-AUG-2002
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The information in this article applies to:
- Microsoft Systems Management Server version 1.2 SP4
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SYMPTOMS
========
Systems Management Server (SMS) clients may ignore the expiration time and date
of newly detected jobs for a workstation. For example, if a job is sent to
several workstations at 9:00 P.M. with an expiration of time of 4:00 A.M. the
following morning, computers that are turned off during this time initially find
out about the job after the expiration time and date. However, in this case, the
Package Command Manager (PCM) process on these clients still attempts to run the
job during the first evaluation cycle.
CAUSE
=====
This behavior is caused by inappropriate handling of newly available jobs during
the first evaluation performed by PCM.
RESOLUTION
==========
A supported fix is now available from Microsoft, but it is only intended to
correct the problem that is described in this article. Only apply it to systems
that are experiencing this specific problem. This fix may receive additional
testing. Therefore, if you are not severely affected by this problem, Microsoft
recommends that you wait for the next Systems Management Server service pack
that contains this fix.
To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information about support costs, visit the following Microsoft
Web site:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
NOTE: In special cases, charges that are ordinarily incurred for support calls
may be canceled if a Microsoft Support Professional determines that a specific
update will resolve your problem. The usual support costs will apply to
additional support questions and issues that do not qualify for the specific
update in question.
The English version of this fix should have the following file attributes or
later:
Date Time Size File name Platform Version
-------------------------------------------------------------
04/22/2000 11:01a 800528 Pcmsvc32.exe Alpha 1.2.0.0
04/22/2000 10:59a 1174288 Pcmwin32.exe Alpha 1.2.0.0
04/22/2000 10:57a 242336 Pcmdos_2.exe I386
04/22/2000 10:57a 276896 Pcmdos_4.exe I386
04/22/2000 10:58a 270304 Pcmsvc32.exe I386 1.2.0.0
04/22/2000 10:58a 453984 Pcmwin16.exe I386 1.2.0.0
04/22/2000 10:57a 469408 Pcmwin32.exe I386 1.2.0.0
NOTE: Due to file dependencies, the most recent hotfix or feature that contains
the above files may also contain additional files.
STATUS
======
Microsoft has confirmed this to be a problem in Systems Management Server
version 1.2 SP4.
MORE INFORMATION
================
To install the hotfix, use the appropriate method.
Alpha-Based Systems Management Server Site Server
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1. Stop the Package Command Manager and Systems Management Server Executive
services.
2. Replace the Pcmsvc32.exe file in the
<SMS_root>\Site.srv\<Platform>.bin folder with the hotfix
version. You must reset the site for the hotfix file to be copied to all
servers managed by Site Configuration Manager. Microsoft Windows NT
Workstation-based computers that are running Pcmsvc32 must be updated by
using Rservice.
3. Replace the Pcmwin32.exe file in the
<SMS_root>\Site.srv\Maincfg.box\Client.src\<Platform>.bin folder
with the hotfix version.
4. Restart the PCM and Systems Management Server Executive services.
Intel-Based Systems Management Server Site Server
-------------------------------------------------
1. Stop the PCM and Systems Management Server Executive services.
2. Replace the Pcmsvc32.exe file in the
<SMS_root>\Site.srv\<Platform>.bin folder with the hotfix
version. You must reset the site for the hotfix file to be copied to all
servers managed by Site Configuration Manager. Windows NT Workstation-based
computers that are running Pcmsvc32 must be updated by using Rservice.
3. Replace the Pcmwin32.exe file in the
<SMS_root>\Site.srv\Maincfg.box\Client.src\<Platform>.bin folder
with the hotfix version.
4. Replace the Pcmdos_2.exe file in the
<SMS_root>\Site.srv\Maincfg.box\Client.src\X86.bin folder with the
hotfix version.
5. Replace the Pcmdos_4.exe file in the
<SMS_root>\Site.srv\Maincfg.box\Client.src\X86.bin folder with the
hotfix version.
6. Replace the Pcmwin16.exe file in the
<SMS_root>\Site.srv\Maincfg.box\Client.src\X86.bin folder with the
hotfix version.
7. Restart the PCM and Systems Management Server Executive services.
Maintenance Manager replicates the updated files to the Systems Management Server
logon servers during its next work cycle. To update the clients, either manually
run Upgrade.bat on each client or follow the instructions in the following
article in the Microsoft Knowledge Base:
Q166771 SMS: How to Force Site-Wide Client Updates
Additional query words: prodsms
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Keywords : kbsms120 kbsms120bug
Technology : kbSMSSearch kbSMS120SP4
Version : winnt:1.2 SP4
Issue type : kbbug
Solution Type : kbfix
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