Q249121: SMS: COMMIT TRANSACTION Request Has No BEGIN TRANSACTION
Article: Q249121
Product(s): Microsoft Systems Management Server
Version(s): 2.0,2.0 SP1,2.0 SP2
Operating System(s):
Keyword(s): kbConfig kbDatabase kbMMC kbServer kbsms200 kbsms200bug kbStatSum kbsms200preSP3fix kbs
Last Modified: 06-AUG-2002
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The information in this article applies to:
- Microsoft Systems Management Server versions 2.0, 2.0 SP1, 2.0 SP2
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SYMPTOMS
========
The following status message may appear sporadically in the Systems Management
Server (SMS) site database at the central site in a large site hierarchy:
SMS_COMPONENT_STATUS_SUMMARIZER 620 Microsoft SQL Server reported SQL message
3902, severity 16: The COMMIT TRANSACTION request has no corresponding BEGIN
TRANSACTION. Please refer to your SMS documentation, SQL documentation, or
the Microsoft Knowledge Base for further troubleshooting information.
Thousands of these messages may occur per day, and status summaries for site
systems may be incomplete temporarily, depending on whether the table involved
(Summarizers_Status) in the deadlock was updated in the last attempt.
CAUSE
=====
A deadlock occurs between the Site System Status summarizer and the Component
Status summarizer.
RESOLUTION
==========
To resolve this problem, obtain the latest service pack for Systems Management
Server version 2.0. For additional information, click the following article
number to view the article in the Microsoft Knowledge Base:
Q288239 SMS: How to Obtain the Latest Systems Management Server 2.0 Service
Pack
WORKAROUND
==========
This condition does not necessarily cause issues with site functionality, but
does cause a large number of status messages to be generated. To work around
this behavior, use either of the following methods.
Method 1
--------
Reduce the frequency of replication for the site system status from each of the
child sites:
1. In the Administrator console, for each site in your hierarchy, expand Site
Hierarchy, <Site Name>, Site Settings, and Status Summarizers.
2. Right-click Site System Status Summarizer, and then click Properties.
3. Click the Schedule button, and then assign a summarization schedule that
occurs less often than once an hour. For example, assign a summarization
schedule that occurs once every eight hours or once each day.
4. Commit the changes.
Method 2
--------
Prevent the status messages from being loaded in the site database or forwarded
to the summarizers with a Status Filter rule:
1. In the Administrator console, for each site where the error message is
reported, expand Site Hierarchy, <Site Name>, Site Settings, and Status
Filter Rules.
2. Right-click the Status Filter Rules node, point to New, and then click Status
Filter Rule.
3. Type a name for the Status Filter rule (for example, "Exclude
SMS_COMPONENT_STATUS_SUMMARIZER 620 Messages").
4. Click to select the Message ID check box. Type "620" (without the quotation
marks) in the box to the right.
5. Click the Action tab.
6. Click the following options:
- "Do not forward to status summarizers"
- "Do not process lower-priority status filter rules"
7. Click OK.
8. Right-click the new Status Filter rule, point to All Tasks, and then click
Increment Priority. Repeat this step until the Status Filter rule appears at
the top of the list. This causes the rule to be processed first, discarding
any status messages with an ID of 620 before writing them to the database or
passing them on to the Component Status summarizer.
NOTE: This procedure prevents all messages with an ID of 620 from being written
to the database or tallied by the Component Status summarizer. Use caution when
you configure Status Filter rules to exclude status messages because you may
inadvertently exclude important information.
STATUS
======
Microsoft has confirmed that this is a problem in the Microsoft products that
are listed at the beginning of this article. This problem was first corrected in
Systems Management Server 2.0 Service Pack 3.
REFERENCES
==========
For additional information, click the article number below to view the article
in the Microsoft Knowledge Base:
Q264378 SMS: Site System Summarizer May Deadlock
Additional query words: prodsms
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Keywords : kbConfig kbDatabase kbMMC kbServer kbsms200 kbsms200bug kbStatSum kbsms200preSP3fix kbsms200SP3fix
Technology : kbSMSSearch kbSMS200 kbSMS200SP1 kbSMS200SP2
Version : :2.0,2.0 SP1,2.0 SP2
Issue type : kbbug
Solution Type : kbfix
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