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Q247279: XADM: How to Rebuild a Deleted Organizational Forms Library

Article: Q247279
Product(s): Microsoft Exchange
Version(s): 4.0,5.0,5.5
Operating System(s): 
Keyword(s): exc4 exc5 exc55
Last Modified: 17-MAR-2001

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The information in this article applies to:

- Microsoft Exchange Server, versions 4.0, 5.0, 5.5 
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SYMPTOMS
========

When you use Microsoft Outlook to create an organizational forms library, when
you click New, and then click Choose Form, the Organizational forms library
option is unavailable.

CAUSE
=====

This issue can occur if the Organization Forms system folder has been deleted
and no replica of the folder exists. If you use the Forms Administrator in the
Microsoft Exchange Server Administrator program to remove the Organization Forms
system folder, all the individual organization forms are deleted at the same
time.

This issue can also occur if you use the Forms Administrator to remove an
Organizational Forms Library which has the same name and same language as the
Organization Forms system folder.

NOTE: "Organizational Forms" is the default name of this folder.

For additional information, click the article number below to view the article in
the Microsoft Knowledge Base:

  Q175129 XADM: Wrong Organization Form Library Deleted in Forms Administrator

RESOLUTION
==========

If you deleted the Organization Forms system folder, first re-create a blank
Organization Forms system folder on the production server:

1. Start the Administrator program.

2. Click Forms Administrator on the Tools menu, and then click New.

Then, recover the individual organizational forms. To do so, perform an online or
offline restore of only the private and public information store to a recovery
server. Do not restore the Exchange Server folder.

To successfully complete this procedure:

1. Confirm that the recovery server has a different NetBIOS name, and that it is
  running the same version of Exchange Server and the Exchange Server service
  packs and hotfixes, and the same version of Windows NT and Windows NT service
  packs and hotfixes.

2. Confirm that the recovery server was installed with the same Exchange Server
  organization and site name, and that the "Create a New Site" option was
  selected. Do not join an existing site, and do not set up connectors to the
  existing organization or site.

3. After you install Exchange Server, and the appropriate Exchange Server
  service packs and hotfixes on the recovery server (if necessary), stop the
  information store.

4. Delete all the files in the Mdbdata folders on all logical drives.

5. If you are performing an online restore, restore both the private and public
  information store. If you are performing an offline restore, you only need to
  restore the public information store. Do not restore the Exchange Server
  folder.

6. Start the Exchange Server information store service.

7. Start the Administrator program, and then click the server.

8. On the File menu, click Properties, and then click the Advanced tab.

9. In Exchange Server 4.0 and 5.0, click DS/IS Consistency, click All, and then
  click the Adjust button.

  In Exchange Server 5.5, click Consistency Adjuster, click All, and then in the
  "Synchronize with the directory" box, reset the home server value for public
  folders homed in unknown sites.

For additional information, click the article number below to view the article in
the Microsoft Knowledge Base:

  Q195519 How to Recover When the Transaction Log Drive Fails

Then, use Microsoft Outlook to create a user account that has Owner permissions
on the Organization Forms folder. You can use either of the following methods to
set the permissions:

- Method One:

  1. Start the Administrator program, click System Folders, and then click
     EFORMS REGISTRY.

  2. Click Organization Forms, click Properties on the File menu, and then
     click the General tab.

  3. Click Client permissions, and then set the appropriate permissions.

- Method Two:

  1. Start the Administrator program, and then click Forms Administrator on the
     Tools menu.

  2. Click the folder, click Organization Forms, and then click Permissions.

Finally, restore the organization forms:

1. Log on to the recovery server using the Outlook client user account that you
  created in the preceding section.

2. Use Outlook to create a Personal Folders service for the profile to create a
  .pst file.

3. Save the organization forms from the recovery server to the .pst file.

4. Restore the organization forms from the .pst file to the Organization Forms
  system folder on the production server.

5. Configure public folder replication for the Organization Forms system folder
  in your organization.

For additional information, click the article number below to view the article in
the Microsoft Knowledge Base:

  Q190994 How to Save Organizational Forms to a PST File

If you have clients that use .ost files, change the default permissions for the
Organization Forms system folder to Reviewer so that the client that has .ost
files can synchronize all folders.

For additional information, click the article numbers below to view the articles
in the Microsoft Knowledge Base:

  Q162703 OST Synch Problem After Org Forms Library Deleted

  Q165462 XCLN: Unable to Access Exchange Forms in the ORG Forms Library

Additional query words:

======================================================================
Keywords          : exc4 exc5 exc55 
Technology        : kbExchangeSearch kbExchange500 kbExchange550 kbExchange400 kbZNotKeyword2
Version           : :4.0,5.0,5.5
Issue type        : kbprb

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