Q246467: RAS Server Stops Responding to New PPP Connection Requests
Article: Q246467
Product(s): Microsoft Windows NT
Version(s): 4.0
Operating System(s):
Keyword(s): kbWinNT400PreSP7Fix
Last Modified: 08-MAY-2002
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The information in this article applies to:
- Microsoft Windows NT Server version 4.0
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SYMPTOMS
========
A Windows NT 4.0-based server that is running Remote Access Services (RAS) may
stop responding to new Point-to-Point protocol (PPP) requests from clients. When
this occurs, the server appears to continue servicing existing PPP connections,
but no new connections are accepted.
This problem occurs only on multiple-processor computers, on which PPP logging is
enabled on the server.
CAUSE
=====
When two threads attempt to write to the PPP log file at the same time, a
problem in the kernel may cause the thread that is currently writing to the file
to enter a wait state from which it never returns. Because the PPP process
cannot proceed until log file write operations have finished, the Rasman.exe
process stops responding (hangs), putting the computer into a state in which it
cannot accept more PPP connections.
RESOLUTION
==========
A supported fix is now available from Microsoft, but it is only intended to
correct the problem described in this article and should be applied only to
systems experiencing this specific problem.
To resolve this problem, contact Microsoft Product Support Services to obtain the
fix. For a complete list of Microsoft Product Support Services phone numbers and
information on support costs, please go to the following address on the World
Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
NOTE: In special cases, charges that are normally incurred for support calls may
be canceled, if a Microsoft Support Professional determines that a specific
update will resolve your problem. Normal support costs will apply to additional
support questions and issues that do not qualify for the specific update in
question.
The English-language version of this fix should have the following file
attributes or later:
Date Time Size File name Platform
--------------------------------------------------------------
11/18/1999 04:16p 952,896 Ntkrnlmp.exe i386
11/18/1999 04:14p 932,736 Ntoskrnl.exe i386
11/18/1999 04:13p 1,403,968 Ntkrnlmp.exe Alpha
11/18/1999 04:13p 1,375,744 Ntoskrnl.exe Alpha
WORKAROUND
==========
To work around this problem, disable PPP logging on multiple-processor RAS
servers.
STATUS
======
Microsoft has confirmed this to be a problem in the Microsoft products that are
listed at the beginning of this article.
Additional query words:
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Keywords : kbWinNT400PreSP7Fix
Technology : kbWinNTsearch kbWinNT400search kbWinNTSsearch kbWinNTS400search kbWinNTS400
Version : :4.0
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbfix
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