Q240195: "NET USER /TIMES" Command Does Not Work in Year 2000
Article: Q240195
Product(s): Microsoft Windows NT
Version(s): winnt:3.51,4.0
Operating System(s):
Keyword(s): kbYear2000 kbWinNT4sp6fix
Last Modified: 16-MAY-2002
-------------------------------------------------------------------------------
The information in this article applies to:
- Microsoft Windows NT Workstation versions 3.51, 4.0
- Microsoft Windows NT Server versions 3.51, 4.0
- Microsoft Windows NT Server, Enterprise Edition version 4.0
- Microsoft Windows NT Server version 4.0, Terminal Server Edition
-------------------------------------------------------------------------------
SYMPTOMS
========
In the year 2000, the /times switch does not work correctly with the net user
command. Any day and time range yields one of the following error messages:
- An illegal day range has been supplied.
More help is available by typing NET HELPMSG 3768.
- An illegal time range has been supplied.
More help is available by typing NET HELPMSG 3769.
CAUSE
=====
The time interval for the /times parameter is passed in local time. However, the
information about logon hours in the account database is stored in Universal
Time Coordinate (UTC) time format. Therefore, Net.exe must take the current date
into account for the daylight savings offset. The current algorithm does not
handle the year 2000 (or later) correctly.
RESOLUTION
==========
WINDOWS NT 4.0
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the
individual software update. For information on obtaining the latest service
pack, please go to:
- http://www.microsoft.com/windows/servicepacks/
-or-
- Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack
For information on obtaining the individual software update, contact Microsoft
Product Support Services. For a complete list of Microsoft Product Support
Services phone numbers and information on support costs, please go to the
following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
If you are running Windows NT 4.0 Service Pack 5:
To determine if a localized version of this software update is available, change
"USA" in the URL above to the appropriate localized abbreviation. Click here
(ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/readme.txt) for a list
of these abbreviations.
If you are running Windows NT 4.0 Service Pack 4:
To determine if a localized version of this software update is available, change
"USA" in the URL above to the appropriate localized abbreviation. Click here
(ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/readme.txt) for a list
of these abbreviations.
If you are running Windows NT 4.0 Service Pack 3:
To determine if a localized version of this software update is available, change
"USA" in the URL above to the appropriate localized abbreviation. Click here
(ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/readme.txt) for a list
of these abbreviations.
WINDOWS NT SERVER 4.0, TERMINAL SERVER EDITION
A supported software update that corrects this problem is now available from
Microsoft, but it has not been fully regression tested and should be applied
only to systems experiencing this specific problem. If you are not severely
affected by this specific problem, Microsoft recommends that you wait for the
next Windows NT Server 4.0, Terminal Server Edition service pack that contains
this software update.
To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the software update. For a complete list of Microsoft Product Support
Services phone numbers and information on support costs, please go to the
following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
The English version of this software update should have the following file
attributes or later:
Date Time Size File name Platform
-------------------------------------------------------
08/25/99 09:11p 142,096 net1.exe x86
08/25/99 09:09p 235,792 net1.exe Alpha
To determine if a localized version of this software update is available, change
"USA" in the URL above to the appropriate localized abbreviation. Click here
(ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/readme.txt) for a list
of these abbreviations.
WINDOWS NT 3.51
A supported software update that corrects this problem is now available from
Microsoft, but it has not been fully regression tested and should be applied
only to systems experiencing this specific problem.
To resolve this problem, contact Microsoft Product Support Services to obtain the
fix. For a complete list of Microsoft Product Support Services phone numbers and
information on support costs, please go to the following address on the World
Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
The English version of this software update should have the following file
attributes or later:
Date Time Size File name Platform
-------------------------------------------------------
08/25/99 09:11p 142,096 net1.exe x86
08/25/99 09:09p 235,792 net1.exe Alpha
If you are running Windows NT 3.51 Service Pack 5:
To determine if a localized version of this software update is available, change
"USA" in the URL above to the appropriate localized abbreviation. Click here
(ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/readme.txt) for a list
of these abbreviations.
STATUS
======
WINDOWS NT 4.0
Microsoft has confirmed this to be a problem in Windows NT 4.0 and Windows NT
Server 4.0, Terminal Server Edition. This problem was first corrected in Windows
NT Server version 4.0, Terminal Server Edition Service Pack 6.
WINDOWS NT SERVER 4.0, TERMINAL SERVER EDITION
Microsoft has confirmed this to be a problem in Windows NT Server 4.0, Terminal
Server Edition.
WINDOWS NT 3.51
Microsoft has confirmed this to be a problem in Windows NT 3.51.
Additional query words: y2k
======================================================================
Keywords : kbYear2000 kbWinNT4sp6fix
Technology : kbWinNTsearch kbWinNTWsearch kbWinNTW400 kbWinNTW400search kbWinNT351search kbWinNT400search kbWinNTW351search kbWinNTW351 kbWinNTSsearch kbWinNTSEntSearch kbWinNTSEnt400 kbWinNTS400search kbWinNTS400 kbWinNTS351 kbNTTermServ400 kbNTTermServSearch kbWinNTS351search
Version : winnt:3.51,4.0
Issue type : kbbug
Solution Type : kbfix
=============================================================================
THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.
Copyright Microsoft Corporation 1986-2002.