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Q240087: Restoring NTBackup Sets Generated by Faulty SP4 Tandqic.sys

Article: Q240087
Product(s): Microsoft Windows NT
Version(s): winnt:4.0 SP4
Operating System(s): 
Keyword(s): kbenv kbhw kbtool kbWinNT4sp6fix kbHardware
Last Modified: 11-JUN-2002

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The information in this article applies to:

- Microsoft Windows NT Server version 4.0, Terminal Server Edition 
- Microsoft Windows NT Server version 4.0 SP4 
- Microsoft Windows NT Workstation version 4.0 SP4 
- Microsoft Windows NT Server, Enterprise Edition version 4.0 SP4 
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IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

  Q256986 Description of the Microsoft Windows Registry

SYMPTOMS
========

When you use the the NTBackup program in conjunction with the Tandqic.sys driver
provided in Windows NT 4 Service Pack 4 (SP4) to restore data from a tape backup
on a Tandberg SLR5 tape drive, you may not be able to restore the data. You may
not be able to retrieve the backup catalog or restore single files. Even though
you can successfully backup data to a tape in the SLR5 drive, you may find that
you receive confirmation of a successful restore operation when in fact, no data
is restored.

CAUSE
=====

This behavior occurs because certain registry values for the NTBackup program
need to be set to 0 instead of the default ("1") and some registry flags need to
be modified for the backup files (created with the SP4 Tandqic.sys driver) to be
restored.

RESOLUTION
==========

Windows NT Server or Workstation 4.0
------------------------------------

To resolve this problem, obtain the latest service pack for Windows NT 4.0. For
additional information, please see the following article in the Microsoft
Knowledge Base:

  Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack

WARNING: If you use Registry Editor incorrectly, you may cause serious problems
that may require you to reinstall your operating system. Microsoft cannot
guarantee that you can solve problems that result from using Registry Editor
incorrectly. Use Registry Editor at your own risk.

To resolve this issue, you can use the Regset.exe utility, located in the Windows
NT 4.0 Service Pack 6 \Support\Utils\i386 folder, to automatically adjust the
pertinent registry entries so that data can be restored from a tape backup that
was created with a computer running Windows NT 4.0 Service Pack 4.

You can also manually modify the registry settings that control the NTBackup
program when using the Tandqic.sys driver. To do this:

1. Start Registry Editor (Regedt32.exe).

2. Locate the "Use fast file restore" value under the following key in the
  registry:

  HKEY_LOCAL_CURRENT_USER\Software\Microsoft\Ntbackup\Backup Engine

3. On the Edit menu, click String, type "0" (without the quotation marks), and
  then click OK.

4. Locate the "Use Tape Catalogs" value under the following key in the
  registry:

  HKEY_LOCAL_CURRENT_USER\Software\Microsoft\Ntbackup\User Interface

5. On the Edit menu, click String, type "0" (without the quotation marks), and
  then click OK.

6. Quit Registry Editor.


Windows NT Server 4.0, Terminal Server Edition
----------------------------------------------

To resolve this problem, obtain the latest service pack for Windows NT Server
4.0, Terminal Server Edition. For additional information, please see the
following article in the Microsoft Knowledge Base:

  Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS
======

Microsoft has confirmed this to be a problem in Windows NT 4.0 and Windows NT
Server 4.0, Terminal Server Edition.

This problem was first corrected in Windows NT Server 4.0 Service Pack 6 and
Windows NT Server 4.0, Terminal Server Edition Service Pack 6.

MORE INFORMATION
================

For additional information about Tandberg tape drives and their compatibility
with the Ntbackup.exe program, contact Tandberg Technical Support at (800)
258-8285 or visit their Web site at:

  http://www.tandberg.com

Additional query words:

======================================================================
Keywords          : kbenv kbhw kbtool kbWinNT4sp6fix kbHardware 
Technology        : kbWinNTsearch kbWinNTWsearch kbWinNTW400search kbWinNT400search kbWinNTW400sp4 kbWinNTSsearch kbWinNTSEntSearch kbWinNTSEnt400sp4 kbWinNTS400sp4 kbWinNTS400search kbNTTermServ400 kbNTTermServSearch
Version           : winnt:4.0 SP4
Hardware          : x86
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

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