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Q231308: Glue NS Records Are Lost When You Add Additional NS Records

Article: Q231308
Product(s): Microsoft Windows NT
Version(s): winnt:4.0
Operating System(s): 
Keyword(s): 
Last Modified: 18-NOV-2000

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The information in this article applies to:

- Microsoft Windows NT Server version 4.0, Terminal Server Edition 
- Microsoft Windows NT Server, Enterprise Edition version 4.0 
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SYMPTOMS
========

If you add an NS record to a DNS zone, when you restart the DNS server the glue
NS records are missing. For example:

You have a DNS domain called mycompany.com. You also have a delegated subdomain
called sales.mycompany.com that contains an existing NS record for the primary
server called srv1.sales.mycompany.com. When you look in the zone file, the
following records are displayed:

  Sales        NS  srv1.sales
  srv1.sales   A   10.2.112.5

For fault tolerance and load balancing, you want to add another NS record for the
sales.mycompany.com zone using the DNS Administration tool for
srv2.sales.mycompany.com. After you add the record, everything appears to
function normally.

After you restart the DNS server, the entries for srv1 are missing in the DNS
Administration tool and in the zone file. This is evident in the zone files when
you click Update Server Data Files, but srv1.sales.mycompany.com is still
visible in the Administration tool.

CAUSE
=====

This behavior occurs because the server writes records in ascending authority
level.

When the DNS Administration tool causes the DNS server to add an NS record to the
database, the server assigns the record the same authority level as other
records in the zone. The server also inserts them at the beginning of a list of
NS records for the subzone. However, the DNS server assigns a slightly lower
authority level to those records when reading the NS records from the zone file
at startup.

Because the new records have the highest authority level and are the first in the
list, the existing records that are read from the zone file are dropped.

RESOLUTION
==========

To resolve this problem, obtain the latest service pack for Windows NT 4.0. For
additional information, please see the following article in the Microsoft
Knowledge Base:

  Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack

File details:

  Date      Time             Size    File Name   Platform
  -------------------------------------------------------
  06/29/99  00:25            177.424 Dns.exe     Intel
  06/29/99  00:24            297.744 Dns.exe     Alpha

WORKAROUND
==========

To work around this problem, use the appropriate method:

- When you need to add NS records, delete all existing records and then add
  them again (including the new records). This is a time-intensive method if
  you have many existing records.

- Edit the zone file directly, instead of using the DNS Administration tool. In
  this case, you need to restart the service so the changes are available.

STATUS
======

Microsoft has confirmed this to be a problem in Windows NT 4.0. This problem was
first corrected in Windows NT 4.0 Service Pack 6.

Additional query words:

======================================================================
Keywords          :  
Technology        : kbWinNTsearch kbWinNT400xsearch kbWinNTSsearch kbWinNTSEntSearch kbWinNTSEnt400 kbWinNTS400xsearch kbNTTermServ400 kbNTTermServSearch
Version           : winnt:4.0
Issue type        : kbprb
Solution Type     : kbpending

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