KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q229012: "Hard Error" with Disconnected WinStation Sessions

Article: Q229012
Product(s): Microsoft Windows NT
Version(s): winnt:4.0,4.0 SP4
Operating System(s): 
Keyword(s): kbWinNT400sp5fixkbfixlist
Last Modified: 11-JUN-2002

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Windows NT Server versions 4.0, 4.0 SP4, Terminal Server Edition 
-------------------------------------------------------------------------------

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

  Q256986 Description of the Microsoft Windows Registry

SYMPTOMS
========

Terminal Server clients go into a "down" state and cannot be reset.

CAUSE
=====

If a disconnected session has an active "Hard Error" dialog box that is
generated by a DOS or 16-bit program, it cannot be reset. If a reset is
attempted on the workstation, it stays in a "down" state until the computer is
restarted.

RESOLUTION
==========

To resolve this problem, obtain the latest service pack for Windows NT Server
4.0, Terminal Server Edition. For additional information, please see the
following article in the Microsoft Knowledge Base:

  Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack


WORKAROUND
==========

To work around this problem, you can disable dialog boxes from ever being
displayed. This is done with a registry setting. For additional information,
please see the following article(s) in the Microsoft Knowledge Base:

  Q124873 Disabling System Hard Error Message Dialog Boxes

WARNING: If you use Registry Editor incorrectly, you may cause serious problems
that may require you to reinstall your operating system. Microsoft cannot
guarantee that you can solve problems that result from using Registry Editor
incorrectly. Use Registry Editor at your own risk.

1. Start Registry Editor (Regedt32.exe).

2. Go to the following key:

  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows\ErrorMode

3. Change the default value of 0 to 2. The following table defines the three
  possible values for ErrorMode:

  Value   Result
  -----   ----------------------------------------------------------------
    0     Errors are serialized and wait for a response.

    1     If the error does not come from the system, then the system
          continues in normal operating mode. If the error comes from the
          system, then it is written to the system log; no user
          intervention is required and dialog boxes are not displayed.

    2     The error is written to the system log; the dialog box is not
          displayed.

STATUS
======

Microsoft has confirmed this to be a problem in Windows NT Server 4.0, Terminal
Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack
5.


Additional query words:

======================================================================
Keywords          : kbWinNT400sp5fix kbfixlist
Technology        : kbWinNTsearch kbWinNT400search kbWinNTSsearch kbWinNTS400search kbNTTermServ400 kbNTTermServ400sp4 kbNTTermServSearch
Version           : winnt:4.0,4.0 SP4
Hardware          : x86
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.