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Q222997: XADM: Importing a Large CSV Hangs and Eventually Consumes All Me

Article: Q222997
Product(s): Microsoft Exchange
Version(s): winnt:5.0
Operating System(s): 
Keyword(s): kbExchange500preSP3fix
Last Modified: 08-MAY-2002

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The information in this article applies to:

- Microsoft Exchange Server, version 5.0 
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SYMPTOMS
========

DAPI batch import may stop responding (hang) or take a long time to complete and
the computer may eventually run out of virtual memory space.

CAUSE
=====

The import routines that check for modified values did not register the fact
that previous values had already been checked. This caused an exponential growth
in the number of passes (and memory allocation) made during the import.

RESOLUTION
==========

A supported fix is now available from Microsoft, but it is only intended to
correct the problem described in this article and should be applied only to
systems experiencing this specific problem. This fix may receive additional
testing at a later time, to further ensure product quality. Therefore, if you
are not severely affected by this problem, Microsoft recommends that you wait
for the next Microsoft Exchange Server version 5.0 service pack that contains
this fix.

To resolve this problem immediately, contact Microsoft Product Support Services
to obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information about support costs, please go to the following
address on the World Wide Web:

  http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

NOTE: In special cases, charges that are normally incurred for support calls may
be canceled, if a Microsoft Support Professional determines that a specific
update will resolve your problem. Normal support costs will apply to additional
support questions and issues that do not qualify for the specific update in
question.

The English version of this fix should have the following file attributes or
later:

Component: Administrator Program

+------------------------+
| File name | Version    | 
+------------------------+
| Dapi.dll  | 5.0.2232.0 | 
+------------------------+



STATUS
======

Microsoft has confirmed this to be a problem in Microsoft Exchange Server
version 5.0.

Additional query words:

======================================================================
Keywords          : kbExchange500preSP3fix 
Technology        : kbExchangeSearch kbExchange500 kbZNotKeyword2
Version           : winnt:5.0
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

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