Q219380: SP4 RAS Server Hangs Up When RAS Client Tries to Connect
Article: Q219380
Product(s): Microsoft Windows NT
Version(s): winnt:4.0,4.0 SP4
Operating System(s):
Keyword(s): kbWinNT400sp5fix
Last Modified: 16-MAY-2002
-------------------------------------------------------------------------------
The information in this article applies to:
- Microsoft Windows NT Server versions 4.0, 4.0 SP4
-------------------------------------------------------------------------------
SYMPTOMS
========
When a Microsoft Windows NT 4.0 RAS client tries to connect to a RAS server
computer running Windows NT Server 4.0 Service Pack 4, the RAS server
unexpectedly hangs up the connection.
CAUSE
=====
This problem occurs because the Ndiswan.sys driver for the RAS server in this
particular hardware configuration becomes deadlocked. The deadlock occurs in the
code that causes the NdisWanSend() API call to quit without contacting the RAS
client. The RAS server then hangs up.
RESOLUTION
==========
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or
the individual software update. For information on obtaining the latest service
pack, please go to:
- http://www.microsoft.com/windows/servicepack
-or-
- Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack
For information on obtaining the individual software update, contact Microsoft
Product Support Services. For a complete list of Microsoft Product Support
Services phone numbers and information on support costs, please go to the
following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
STATUS
======
Microsoft has confirmed this to be a problem in Windows NT Server 4.0 and
Windows NT Server 4.0 Service Pack 4. This problem was first corrected in
Windows NT Server 4.0 Service Pack 5.
Additional query words:
======================================================================
Keywords : kbWinNT400sp5fix
Technology : kbWinNTsearch kbWinNT400search kbWinNTSsearch kbWinNTS400sp4 kbWinNTS400search kbWinNTS400
Version : winnt:4.0,4.0 SP4
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbfix
=============================================================================
THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.
Copyright Microsoft Corporation 1986-2002.