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Q216711: After SDLC Outage, SNA Server Takes 5-10 Seconds to Recover

Article: Q216711
Product(s): Microsoft SNA Server
Version(s): WINDOWS:3.0,3.0SP1,3.0SP2,3.0SP3,4.0,4.0SP1,4.0SP2
Operating System(s): 
Keyword(s): kbsna300sp4fix kbsna400sp3fix
Last Modified: 11-JUN-2002

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The information in this article applies to:

- Microsoft SNA Server, versions 3.0, 3.0SP1, 3.0SP2, 3.0SP3, 4.0, 4.0SP1, 4.0SP2 
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SYMPTOMS
========

IMPORTANT: This article contains information about modifying the registry.
Before you modify the registry, make sure to back it up and make sure that you
understand how to restore the registry if a problem occurs. For information
about how to back up, restore, and edit the registry, click the following
article number to view the article in the Microsoft Knowledge Base:

  Q256986 Description of the Microsoft Windows Registry

After receiving an outage (connection failure) from the IBM SDLC link service,
SNA Server takes from 5 to 10 seconds before posting a CLOSE(LINK), and
subsequent new OPEN(LINK) to retry connection activation. During this time, the
host may stop retrying the PU, and may set the PU to an inactive status,
requiring manual host intervention to recover the SDLC connection.

CAUSE
=====

SNA Server intentionally delays SDLC connection recovery to ensure that the SNA
Server DACTPU reply has an opportunity to be sent by the link service to the
host. However, in a certain customer environment, this 5 to 10 second delay
exceeded the host's SDLC connection recovery time period.

RESOLUTION
==========

SNA Server 4.0
--------------

To resolve this problem, obtain the latest service pack for SNA Server version
4.0. For additional information, please see the following article in the
Microsoft Knowledge Base:

  Q215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack


SNA Server 3.0
--------------

To resolve this problem, obtain the latest service pack for SNA Server version
3.0. For additional information, please see the following article in the
Microsoft Knowledge Base:

  Q184307 How to Obtain the Latest SNA Server Version 3.0 Service Pack


STATUS
======

Microsoft has confirmed this to be a problem in SNA Server 3.0 (SP1-SP3) and SNA
Server 4.0 (SP1-SP2). This problem was first corrected in SNA Server version 3.0
Service Pack 4 and SNA Server version 4.0 Service Pack 3.

MORE INFORMATION
================

WARNING: If you use Registry Editor incorrectly, you may cause serious problems
that may require you to reinstall your operating system. Microsoft cannot
guarantee that you can solve problems that result from using Registry Editor
incorrectly. Use Registry Editor at your own risk.
After this hotfix is applied, the NoSDLCOutageTimer registry parameter must be
added to eliminate the SDLC connection recovery period. Follow these steps to
add this registry value:

1. Start Registry Editor (Regedt32.exe).

2. Locate the following key in the registry:

  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SnaServr\Parameters\
 

  NOTE: The above registry key is one path; it has been wrapped for readability.

3. On the Edit menu, click Add Value, and then add the following registry value:

     Value Name: NoSDLCOutageTimer
     Data Type:  REG_SZ
     Value:      <any value> (the presence of the registry key enables support)
 

4. Quit Registry Editor.

Additional query words:

======================================================================
Keywords          : kbsna300sp4fix kbsna400sp3fix 
Technology        : kbAudDeveloper kbSNAServSearch kbSNAServ300 kbSNAServ400
Version           : WINDOWS:3.0,3.0SP1,3.0SP2,3.0SP3,4.0,4.0SP1,4.0SP2
Issue type        : kbbug
Solution Type     : kbfix

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