KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q197289: XFOR: Internet Mail Service May Not Save Turfed Messages

Article: Q197289
Product(s): Microsoft Exchange
Version(s): winnt:5.5
Operating System(s): 
Keyword(s): exc55 EXC55SP3Fix
Last Modified: 11-JUN-2002

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Exchange Server, version 5.5 
-------------------------------------------------------------------------------


IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

  Q256986 Description of the Microsoft Windows Registry

SYMPTOMS
========

Spoofed messages coming into Exchange Server from the Internet Mail Service may
not be saved as configured in the Windows NT registry. The spoofed messages may
be saved on the system drive or not at all.

CAUSE
=====

The Exchange Server Administrator program in Microsoft Exchange Server version
5.5 Service Pack 1 provides a dialog box (Configuration-Connections- Internet
Mail Service-Connections-Message Filter) for adding originator domains and user
names to the "Turf" table. The Turf table is then used to filter out incoming
messages. If incoming messages are from a user or domain in the Turf table, the
message is not delivered to the Exchange Server recipient. Instead, it is
deleted, or saved in a Turf directory. This directory is set by default in the
Exchange Server Administrator program to be C:\Turfdir. You can change this
location by adjusting the following registry key:

  HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\Services\MSExchangeIMC
  \Parameters\Turfdir

However, every time you add a domain or user to the Turf table through the
Message Filter in the Exchange Server Administrator program, the Turf directory
is reset to the default location. If the default location does not have a
Turfdir directory created, the messages will not be saved.

For more information on Turf tables and Turf directories, please see the
following Microsoft Knowledge Base articles:

  Q155683 XFOR: Verification of FROM Address in SMTP Messages

  Q193926 XFOR: TURFDIR Must Be Manually Created for Message Filtering

RESOLUTION
==========

To resolve this problem, obtain the latest service pack for Exchange Server
version 5.5. For additional information, please see the following article in the
Microsoft Knowledge Base:

  Q191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

The English version of this fix should have the following file attributes or
later:

Component: Administrator Program

+---------------------------+
| File name    | Version    | 
+---------------------------+
| Imcadmin.dll | 5.5.2536.0 | 
+---------------------------+


STATUS
======

Microsoft has confirmed this to be a problem in Microsoft Exchange Server
version 5.5. This problem was first corrected in Exchange Server 5.5 Service
Pack 3.

Additional query words:

======================================================================
Keywords          : exc55 EXC55SP3Fix 
Technology        : kbExchangeSearch kbExchange550 kbZNotKeyword2
Version           : winnt:5.5
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.