KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q184506: Err Msg: MSN Requires a Previous Version of Internet Explorer

Article: Q184506
Product(s): The Microsoft Network
Version(s): WINDOWS:2.5,2.51,2.52,4.0,4.01
Operating System(s): 
Keyword(s): kberrmsg kbsetup kbmsn
Last Modified: 07-JAN-2001

-------------------------------------------------------------------------------
The information in this article applies to:

- The Microsoft Network versions 2.5, 2.51, 2.52 
- Microsoft Internet Explorer versions 4.0, 4.01 for Windows 95 
-------------------------------------------------------------------------------

SYMPTOMS
========

When you attempt to install MSN, The Microsoft Network, version 2.5x, or
Microsoft Internet Explorer version 4.0 or later, you may receive the the
following error message:

  MSN requires a previous version of Internet Explorer.

CAUSE
=====

This behavior can occur if you have different versions of some Windows 95 system
files installed on your computer.

RESOLUTION
==========

To resolve this issue, replace the Ole32.dll and Rpcrt4.dll files from your
original Windows 95 CD-ROM or floppy disks, and then install Internet Explorer
and MSN. To do so, follow these steps:

1. Click Start, point to Find, and then click "Files or Folders".

2. In the Named box, type ole32.dll, and then click Find Now.

3. Rename the Ole32.dll file to Ole32.old.For information about how to rename a
  file in Windows, follow these steps:

  a. Click Start, and then click Help.
  b. On the Index tab, type renaming, and then click Display.
  c. Click Changing the name of a file or folder, and then click Display.

4. In the Named box, type rpcrt4.dll, and then click Find Now.

5. Rename the Rpcrt4.dll file to Rpcrt4.old. (See previous step on how to find
  information on renaming files).

6. Repeat steps 4-5 to rename the following files:

  - Jobexec.dll
  - Inseng.dll
  - Digsig.dll

7. Close the Find: Files Named Digsig.dll window.

8. Extract the Ole32.dll and Rpcrt4.dll files from your original Windows 95
  disks or CD-ROM to the <drive>:\Windows\System> folder, where
  <drive> is the letter of the drive where Windows is installed.

  The Ole32.dll file is located in the following locations:

  - The Win95_09.cab cabinet file on the Windows 95 CD-ROM.
  - The Win95_14.cab cabinet file on the Windows 95 OEM Service Release 2 (OSR2)
  CD-ROM.
  - The Win95_09.cab cabinet file on disk 9 of the original Windows 95 DMF
  floppy disks.
  - The Win95_14.cab cabinet file on disk 14 of the original Windows 95 non-DMF
  floppy disks.

  The Rpcrt4.dll files is located in the following locations:

  - The Win95_11.cab cabinet file on the Windows 95 CD-ROM.
  - The Win95_18.cab cabinet file on the Windows 95 OEM Service Release 2 (OSR2)
  CD-ROM.
  - The Win95_12.cab cabinet file on disk 12 of the original Windows 95 DMF
  floppy disks.
  - The Win95_18.cab cabinet file on disk 18 of the original Windows 95 non-DMF
  floppy disks.

  For information about how to use the Extract command, see the following
  article in the Microsoft Knowledge Base: Q129605 <A0>How to Extract Original
  Compressed Windows Files.

9. Restart the computer.

10. Insert the MSN CD-ROM into the CD-ROM drive. Press and hold down the SHIFT
  key when you insert the CD-ROM to prevent the MSN Setup program from
  starting automatically.

11. Double-click My Computer.

12. Right-click the MSN (CD-ROM drive) icon, and then click Explore.

13. Double-click the Ie40 folder or the Ie401folder.

14. Double-click the Ie4setup.exe file. Follow the instructions on the screen to
  install Internet Explorer.

15. Restart the computer.

16. Double-click My Computer.

17. Right-click the MSN (CD-ROM drive) icon, and then click Explore.

18. Double-click the Setup.exe file. Follow the instructions on the screen to
  install MSN.

Additional query words: 4.0 msnet msnetwork microsoft-net m.s.n.

======================================================================
Keywords          : kberrmsg kbsetup kbmsn 
Technology        : kbIEsearch kbMSNSearch kbIE95Search kbZNotKeyword3 kbIE400Win95 kbIE401Win95 kbMSN252 kbMSN251 kbMSN250
Version           : WINDOWS:2.5,2.51,2.52,4.0,4.01
Issue type        : kbprb

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.