Q170628: MTG: MTA Error: Mailbag Truncated by Up_retries
Article: Q170628
Product(s): Microsoft Mail For PC Networks
Version(s): WINDOWS:3.5
Operating System(s):
Keyword(s): kbusage
Last Modified: 30-OCT-1999
-------------------------------------------------------------------------------
The information in this article applies to:
- Microsoft Mail for PC Networks, version 3.5
-------------------------------------------------------------------------------
SYMPTOMS
========
Mail delivery fails and the Session.log of External shows similar entries:
A Critical error has occurred
Data: Error Code~0c, Device Error _14
Mailbag truncated by up_retries
Mail transfer failed.
CAUSE
=====
There is a problem accessing the postoffice because External has failed to read
from disk possibly because of a network connection problem. The error "mailbag
truncated by up_retries" means External had a problem at the time it was
processing mail in the referenced mailbag. These errors together suggest a
failure in the network connection.
RESOLUTION
==========
A network trace may be necessary to pinpoint the connection failure. There is a
short-term workaround that works with the MS-DOS MTA only. A setting in the
External.ini will allow External to restart when it encounters a critcal error.
The setting is:
ReBootOnce
This is not a fix but can be used as a workaround until the cause of the problem
can be determined and resolved.
MORE INFORMATION
================
External will return an error generated by Interrupt 24h in MS-DOS
(Critical-Error Handler).
The "device error = c" means "general failure". Here is the list of other
possible values:
code meaning
---- -----------------------------------
00h write-protected disk
01h unknown unit
02h drive not ready
03h invalid command
04h data error (CRC)
05h bad request structure length
06h seek error
07h non-DOS disk
08h sector not found
09h printer out of paper
0ah write fault
0bh read fault
0ch general failure
0fh invalid disk change (dos 3 & later)
Additional query words:
======================================================================
Keywords : kbusage
Technology : kbMailSearch kbZNotKeyword3 kbMailPCN350
Version : WINDOWS:3.5
Issue type : kbprb
=============================================================================
THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.
Copyright Microsoft Corporation 1986-2002.