Q164938: Event Logging Frozen While Doing Heavy Logging
Article: Q164938
Product(s): Microsoft Windows NT
Version(s): 3.51 4.0
Operating System(s):
Keyword(s): kbbuglist kbfixlist
Last Modified: 08-AUG-2001
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The information in this article applies to:
- Microsoft Windows NT Workstation versions 3.51, 4.0
- Microsoft Windows NT Server versions 3.51, 4.0
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SYMPTOMS
========
If you are doing heavy event logging and you have your event log set to wrap
events if the log is full, event logging may stop responding. This in turn may
cause other threads in other processes that may be waiting on the event logging
service to stop responding.
CAUSE
=====
You may also see that the services CPU usage is close to or above 90 percent.
This is because many of the threads in services will be waiting on one thread
that continually spins. The spinning thread is using all the CPU time.
STATUS
======
Microsoft has confirmed this to be a problem in Windows NT version 3.51 and 4.0.
A supported fix is now available, but has not been fully regression-tested and
should be applied only to systems experiencing this specific problem. Unless you
are severely impacted by this specific problem, Microsoft recommends that you
wait for the next service pack that contains this fix. Contact Microsoft
Technical Support for more information.
This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service
Pack. For information on obtaining the service pack, query on the following word
in the Microsoft Knowledge Base (without the spaces):
S E R V P A C K
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Keywords : kbbuglist kbfixlist
Technology : kbWinNTsearch kbWinNTWsearch kbWinNTW400 kbWinNTW400search kbWinNT351search kbWinNT400search kbWinNTW351search kbWinNTW351 kbWinNTSsearch kbWinNTS400search kbWinNTS400 kbWinNTS351 kbWinNTS351search
Version : 3.51 4.0
Issue type : kbbug
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