KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q139530: Multimedia: Using an Asterisk Wildcard Slows Searches

Article: Q139530
Product(s): Microsoft Home Multimedia Titles
Version(s): 
Operating System(s): 
Keyword(s): kbtool kbui kbimu
Last Modified: 09-NOV-2001

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Bookshelf 1996-97 for Windows 
- Microsoft Bookshelf 98 for Windows 
- Microsoft Bookshelf 99 
- Microsoft Bookshelf 2000 
- Microsoft Encarta 1994 The Complete Multimedia Encyclopedia 
- Microsoft Encarta 96 Encyclopedia for Windows 
- Microsoft Encarta 97 Encyclopedia for Windows 
- Microsoft Encarta Encyclopedia 97 Deluxe for Windows 
-------------------------------------------------------------------------------

SYMPTOMS
========

When you use the asterisk (*) wildcard character in an advanced search, the
search process takes an extremely long time to complete.

CAUSE
=====

Wildcard searches using the asterisk character are supported in many multimedia
programs. However, if you type an asterisk followed by the text you are
searching for, the search takes much longer because the query must search
through hundreds of thousands of words to find the words ending with the text
you specified.

RESOLUTION
==========

To avoid long waiting times for search results, enclose the text you are
searching for in quotation marks, or use the following search operators:

- And
- Or
- Not
- Near

MORE INFORMATION
================

If you search for words that start with the text you enter, the search process
is much faster.

For detailed information on how to search for text or keywords, please see the
Search topic in the program's online Help.

Additional query words: multi multi-media media mm

======================================================================
Keywords          : kbtool kbui kbimu 
Technology        : kbHomeProdSearch kbHomeMMsearch kbEncartaSearch kbBookshelfSearch kbEncartaEncycSearch kbBookShelf1996 kbBookShelf1997 kbBookShelf1998 kbBookShelf2000 kbBookShelf1999 kbEncartaEnCyc1996 kbEncartaEnCyc1997 kbEncartaEnCyc1997Del kbEncartaEnCyc1994
Version           : :
Issue type        : kbprb

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.