KnowledgeBase Archive

An Archive of Early Microsoft KnowledgeBase Articles

View on GitHub

Q110615: PROFS: Bottleneck in MS-CSM Causes Multiple Requests

Article: Q110615
Product(s): Microsoft Mail For PC Networks
Version(s): 3.4
Operating System(s): 
Keyword(s): 
Last Modified: 16-NOV-1999

-------------------------------------------------------------------------------
The information in this article applies to:

- Microsoft Mail Gateway to IBM PROFS and OfficeVision, version 3.4 
-------------------------------------------------------------------------------

SYMPTOMS
========

The MS-CSM(Calendar Service Machine) goes into a looping, sends warning
messages, and sends a re-send request to the LAN for each out-of-sequence
free/busy distribution it receives from SCHDIST.EXE (from Microsoft Schedule+
for Windows).

The MS-CSM machine spends time and resources processing these requests, and this
has been known to cause the MS-CSM machine to go into a loop, depleting about
80% of the VM system resources.

The expected behavior would be for the MS-CSM machine to generate only one
re-send for the out of sequence distribution.

CAUSE
=====

MS-CSM cannot wait while a free/busy distribution is being processed by the
MS-CAL machine. Thus, if the next item in the MS-CSM machine's reader is a
distribution update, a warning message is generated. The previous message is
still being processed, which has delayed the MS-CSM machine from updating the
SCHDPLUS CONTROL file with the CONFIRMED flag.

RESOLUTION
==========

Halt the MS-CSM machine and purge all but one of the distributions, causing the
MS-CSM machine to generate only one re-send request.


Additional query words: 3.40

======================================================================
Keywords          :  
Technology        : kbMailSearch kbMailGateSearch kbZNotKeyword3 kbMailGateIBMPROFS340
Version           : :3.4

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1986-2002.