Q106510: PC Adm: Err Msg: Postoffice Address List Already Has an Alias…
Article: Q106510
Product(s): Microsoft Mail For PC Networks
Version(s): WINDOWS:2.1e,3.0,3.0b,3.2
Operating System(s):
Keyword(s):
Last Modified: 31-OCT-1999
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The information in this article applies to:
- Microsoft Mail for PC Networks, versions 2.1e, 3.0, 3.0b, 3.2
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SYMPTOMS
========
With versions 2.1e, 3.0, 3.0b, and 3.2 of Microsoft Mail for PC Networks, when
you create a new user using the Mail Administrator program (ADMIN.EXE), the
following error message may appear:
Notice 58 Postoffice address list already has an alias with this name
CAUSE
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This problem may occur for one or more of the following reasons:
1. One or more of the following files is locked open, marked as Read Only, or
(with Novell networks) ownerless:
ACCESS.GLB
ACCESS2.GLB
ACCESS3.GLB
ADMIN.NME
ADMINSHD.NME
ADMIN.INF
ADMIN.TPL
The ADMIN.INF and ADMIN.TPL files will only be present if a template has been
defined. By default, these files are not present.
2. One or more files on the Microsoft Mail postoffice is corrupt. You can
determine major corruption of files by checking the file sizes.
If any of the following calculations results in a remainder, the corresponding
file is corrupt:
(size of ACCESS.GLB) / 586
(size of ACCESS2.GLB) / 69
(size of ACCESS3.GLB) / 512
(size of ADMIN.NME) / 45
(size of ADMINSHD.NME) / 45
3. The alias being added exists in the postoffice address list but not in the
access files (ACCESS*.GLB), which contain user information.
You can verify this situation using the ADMIN.EXE program by selecting
Local-Admin, Modify. This should display the list of all users defined in the
three access files. Selecting Local-Admin, Group, Create displays the
postoffice address list.
RESOLUTION
==========
The following are corresponding workarounds for the above causes. These steps
are geared for the Mail administrator:
1. If you find any of the files to be marked read only, use the MS-DOS ATTRIB
command to change the attribute on the file to read-write.
If any of the above files are locked open on the server, close the files. The
easiest way to do this is to reboot the server. If rebooting the server is
not feasible, the network operating system should provide a means of closing
files left open on the server.
On a Novell network, if any of the above files are ownerless, use the Novell
FILER command to assign ownership of the file to SUPERVISOR.
2. If you find a corrupted file, please contact Microsoft Product Support
Services.
NOTE: Restoring files from backup may have negative repercussions.
1. If the user alias is present in the Postoffice Address List (POL) but not in
the access files, copy the POL to the Personal Address List (PAL), delete the
user, and then copy the PAL over the POL.
The following procedure assumes that the administrator mailbox still exists
and the 8-digit hexadecimal ID (hexid) is 00000000. If you are using an
account other than 00000000, substitute the 8-digit hexid of that account for
00000000.
a. Obtain the user's mailbox name. From the Administrator program Config
menu, choose Password. Note the postoffice and network names.
b. At the MS-DOS command prompt, change to the NME subdirectory of the Mail
database.
c. Make a backup of the POL by typing the following command:
"copy admin.nme admin.old" (without the quotation marks)
d. Make a backup of your PAL by typing the following command:
"copy 00000000.nme 00000000.old" (without the quotation marks)
If 00000000.NME is a zero-byte file, copying may not work. You can safely
skip this step.
e. Copy the POL to the PAL by typing the following command:
"copy admin.nme 00000000.nme" (without the quotation marks)
f. Move up one directory level from the NME subdirectory (by typing CD..).
g. Start the MS-DOS Mail client and sign in using the admin mailbox by typing
the following command:
"mail admin -p<password>" (without the quotation marks)
h. From the Address menu, choose Delete. (If you have the version 2.1e MS-DOS
client, choose Remove from the Address menu.) This should bring up a list
of users. Select the user you want to delete and press the ENTER key. You
will now be prompted for confirmation to delete the user. Press the ENTER
key again.
i. Quit out of the Mail client.
j. At the MS-DOS command prompt, change to the NME directory of the Mail
database.
k. Copy the PAL to the POL by typing the following command:
"copy 00000000.nme admin.nme
copy 00000000.nme adminshd.nme" (without the quotation marks)
l. Move up one directory level from the NME subdirectory (by typing CD..).
m. Start the Administrator program. You should now be able to add the problem
user account.
Once you have successfully added the user account, delete the ADMIN.OLD file
and copy 00000000.OLD to 00000000.NME. (If you skipped step D above, you do
not need to copy 00000000.OLD to 00000000.NME.)
Additional query words: 2.10e 3.00 3.00b 3.20 admin
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Keywords :
Technology : kbMailSearch kbZNotKeyword3 kbMailPCN320 kbMailPCN300 kbMailPCN300b kbMailPCN210e
Version : WINDOWS:2.1e,3.0,3.0b,3.2
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